Creating Stairs

Created with software version 2020.1

This video demonstrates the steps followed in this tutorial to create a multi-floor stairwell with landings between each floor.

1. Introduction

This example represents an outer section of a dormitory wing with 30 persons randomly distributed inside. The persons will move through their respective halls and down a stairway to exit the model.

2. Create Floor Geometry

To select Metric measurements:

  1. On the View menu, click Units and select SI.

To specify snap grid spacing:

  1. On the View menu, click Edit Snap Grid.
  2. In the Snap grid spacing box, type 1.0 m.
  3. Click OK.

To create the room with a hallway:

  1. In the View toolbar, click Top View path ui icon view 2d top.
  2. In the Tools toolbar, click Add a Rectangular Room path ui icon room rectangular.

  3. We will make a large room and then subdivide it. To add the first room, click and drag from point (4,0) to point (18,8).
  4. Create four additional rooms from (4,0) to (11,3), (11,0) to (18,3), (6,5) to (12,8), and (12,5) to (18,8).

  5. Create the base of the stairwell by drawing a rectangular room from (2,6) to (4,8).
path scrn stairs ground geometry
Figure 1. Geometry of Ground Floor

To quickly make the second and third floors, we will copy the ground floor. For convenience and to help organize our model, we first create two new floors. To create the second floor:

  1. In the Floor options (located above the Tree View), click <Add New>.
  2. Type 4 m for the height of the new floor, then click OK.
  3. In the Tree View, click to select Floor 0.0 m.
  4. In the tools toolbar, click Copy/Move Objects path ui icon copy move. Select Copy Mode. In the Copies box, type 1. In the Move Z box, type 4.0. Click Copy/Move.
  5. The second and third floors have larger landings than the first floor. To edit the size of the second floor landing, right-click Floor 4.0 m and click Set as Active Floor. Using Select/Edit Objects path ui icon select, select the landing of the second floor. Click and drag the top left handle (blue dot on the room) to 0,8 and the bottom left handle to 0,6.

To create the third floor:

  1. In the Floor options (located above the Tree View), click <Add New>.
  2. Type 8 m for the height of the new floor, then click OK.
  3. In the Tree View, click to select Floor 4.0 m.
  4. In the tools toolbar, click Copy/Move Objects path ui icon copy move. Select Copy Mode. In the Copies box, type 1. In the Move Z box, type 4.0. Click Copy/Move.
  5. Because we copied the second floor, we do not need to edit the landing of the third floor.

To show the entire model:

  1. Click the Floor pulldown menu located above the Tree View and select <Show All>.
  2. Click the Perspective View path ui icon view 3d.
  3. Click Reset All path ui icon reset and then spin the model. The model should look similar to Figure 3.
path scrn stairs second floor geometry
Figure 2. After dragging the top left handle of the second floor landing.
path scrn stairs second third floor geometry
Figure 3. After creating the second and third floors

3. Add Landing

Before adding stairs, we add landings between floors. To add the landing between the first and second floors:

  1. In the Floor options (located above the Tree View), click <Add New>.
  2. Type 2 m for the height of the new floor.
  3. In the New Floor dialog box, check Set as active floor. This hides all other floors and causes newly created geometry to be added to the new floor. Click OK.
  4. In the View toolbar, click Top View path ui icon view 2d top.
  5. In the Tools toolbar, click Add a Rectangular Room path ui icon room rectangular. Create a rectangular landing from (0, 0) to (4, 2).

Repeat to add a second landing at 6.0 m. After adding a second landing, your model should resemble Figure 4.

path scrn stairs highlighted landings
Figure 4. After adding landings (highlighted in purple)

4. Add Stairs

To create the stairs, we will use the stair tool that adds a stair between existing floors. To simplify placing the stairs, we will display only the floors of interest when adding the stairs. To add the first stairs:

  1. In the Tree View, hold the CTRL key and select Floor 0.0 m and Floor 2.0 m.
  2. Release the CTRL key and right-click on either of the selected floors. From the context menu, select Filter. Only the first floor and the first landing will be displayed.
  3. Click Create Stairs between two edges path ui icon stair 2.
  4. In the Width box, type 2 m.
  5. Click on the first floor landing, then click on the 2.0 m landing. Your model should resemble Figure 5.
  6. Repeat the above steps and add stairs between Floor 2.0 m and Floor 4.0 m. These stairs are shown in Figure 6.
  7. Repeat to add stairs between Floor 4.0 m and Floor 6.0 m.
  8. Repeat to add stairs between Floor 6.0 m and Floor 8.0 m.

When finished, right-click on Floors in the Tree View and click Show All. The stairs should look as shown in Figure 7.

path scrn stairs stairs 1
Figure 5. After adding stairs between the first floor and the lowest landing
path scrn stairs stairs 2
Figure 6. After adding stairs between the lowest landing and the second floor
path scrn stairs stairs 3
Figure 7. After adding all stairs

5. Add Doors

With the geometry finished, doors can be added. This can be done in the 3D view, but it will be easier to use the Top View and work with one floor at a time. To work in any specific floor, right-click it in the Tree View and select Set as Active Floor or select the floor from the drop-down menu above the tree view.

To add doors to the first floor:

  1. On the View menu, click Edit Snap Grid, type 0.5 m then click OK.
  2. Right-click on Floor 0.0 m and select Set as Active Floor.
  3. In the View toolbar, click Top View path ui icon view 2d top.
  4. Click Add a new Door path ui icon door.
  5. To add a door from the hallway to the stairwell, click and drag from (4, 6.5) to (4, 7.5).
  6. Create 1 m doors to connect each room to the hallway. Click and drag from (9.5, 3.0) to (10.5, 3.0), (11.5, 3.0) to (12.5, 3.0), (10.5, 5.0) to (11.5, 5.0), and (12.5, 5.0) `to `(13.5, 5.0). Your model should resemble Figure 8.

Repeat for Floor 4.0 m and Floor 8.0 m.

Finally, add an exit door on the first floor (Floor 0.0 m) from (4, 8) to (6, 8).

path scrn stairs doors added
Figure 8. After adding doors to the first floor

6. Add Occupants

We now add occupants to each floor.

  1. Right-click on Floor 0.0 m and select Set as Active Floor.
  2. Hold the CTRL key and click on each of the four rooms on the floor to select them.
  3. On the Model menu, click Add Occupants.
  4. In the By Number box, type 20, then click OK.
  5. In the same manner, add 50 occupants to the second floor and 30 occupants to the third floor.

To show the completed model:

  1. On the View toolbar, click Perspective View.
  2. On the View menu, under Agents, click Show as People. Your model should resemble Figure 9.
path scrn stairs finished model
Figure 9. The finished model

The occupants will be assigned the default Behavior, which is to leave the building using any available exit.

7. Run Simulation

To run the simulation:

  1. On the File menu, select Save As…
  2. Save the model to a new folder on your computer and name the file multi_floor_stairwell.pth.
  3. On the toolbar, click Run Simulation path ui icon run sim.

8. View Results

When the simulation is finished, the 3D Pathfinder results window will display.

To view results:

  1. Click the Play button.
  2. At any time click the Pause or Stop button. You can drag the time line to control the animation.
  3. To view occupants as people, click the Stop button, on the Agents menu, click Show as People, then click the Play button.

Detailed information for each room is provided in comma-separated value (CSV) files that can be imported to a spreadsheet. The LAST OUT time is 109.9 seconds for steering behavior.

path scrn stairs simulation results
Figure 10. The 3D results showing stairwell evacuation

9. Selecting SFPE Mode

Pathfinder provides the option to select different simulation modes. The SFPE movement mode is consistent with the assumptions used in the SFPE Engineering Guide - Human Behavior in Fire (SFPE 2019). Assumptions include:

  • The occupants move toward the exits using the shortest path
  • The maximum occupant speed is a function of room density
  • Occupants move independently and can occupy the same space as other occupants
  • Queues form at doors, with the flow rate through the door as specified by SFPE guidelines. Because multiple occupants can occupy the same space, a queue may appear as a single occupant.

To select the SFPE mode:

  1. On the Simulation menu, click Simulation Parameters.
  2. Click the Behavior tab.
  3. In the Behavior Mode box, select SFPE.
  4. In the Door Boundary Layer box, type 0 cm. This removes the boundary layer from the flow calculation of the door
  5. Click OK.

Save the model using the name multi_floor_stairwell_sfpe.pth and run the analysis. The LAST OUT time for SFPE mode is 85.0 seconds.

10. Compare SFPE Calculation with Expected Result

The expected SFPE mode evacuation time can be calculated by hand. The time is the time required for the first occupant from the second floor to exit plus the time for the remaining second and third floor occupants to pass through the door at the bottom of the stairs.

The speed on the stairs is 0.918 m/s. The speed on the floor and landing is 1.19 m/s. The flow rate through a 1.0 m door is 1.32 pers/sec. Figure 11 shows the path of the first person on the second floor highlighted in yellow. The length is approximately 12.9 m. The time for the first person to exit is approximately 10.8 s to reach the landing, 5 s on the landing and exit floor, and 9.7 s on the stairs, for a total time of 25.5 s. The time for 79 people to pass through the 1.0 m door is 59.9 s. The total exit time is then approximately 85.4 s, which is similar to the time calculated by Pathfinder.

path scrn stairs sfpe results
Figure 11. The yellow highlight shows the path of the first person to reach the landing on the second floor. The length of this path is approximately 12.9 m.

To download the most recent version of Pathfinder, please visit the Pathfinder downloads page and click the link for the current release. If you have any questions, please contact support@thunderheadeng.com

11. Bibliography

SFPE. 2019. SFPE Guide to Human Behavior in Fire. 2nd ed. Springer International Publishing. https://www.springer.com/gp/book/9783319946962.