Use a Blueprint to Sketch a Model

Created with software version 2020.1

1. Introduction

This example demonstrates how to import a file as a background image and then create the model by sketching. The image used is the office space of Fog Creek (we use their FogBugz software to track our bug reports) and is displayed at their website. Right click Figure 1 and Save link as with the file name of 15floorplan.png.

doc scrn blueprint floor plan
Figure 1. Image of the office geometry

The following video demonstrates how to import a blueprint in jpg format and then create the Pathfinder evacuation model by sketching on top of the blueprint.

The rest of this tutorial provides a walkthrough of this feature.

2. Import Background Image

To select English measurements:

  1. On the View menu, click Units and select EN.

We will begin by importing the background image for sketching:

  1. On the View menu, uncheck Show Snap Grid. This will allow us to sketch in the 2D view without snapping to the grid.
  2. On the Model menu, click Add a Background Image. Open the 15floorplan.png file. This will display the Configure Background Image dialog.
  3. We first define the "Anchor Point" for the image. Type the coordinates as Model X: 0.0 ft, Model Y: 0.0 ft, and Model Z: 0.0 ft. Click the Choose Anchor Point button and click on the mark in the lower left of the image.
  4. We next define two points that will be used to scale the image geometry and to rotate the image (if needed). Click the Choose Point A button and click on the cross mark in the upper left of the image. Click the Choose Point B button and click on the cross mark in the upper right of the image. In the Dist. A to B textbox, type 166.0 ft.
path ui dialog bakground image anchor point
Figure 2. Define the Anchor Point on the background image. Note the red anchor point
path ui dialog bakground image define points
Figure 3. Define points A and B

3. Sketch the Rooms

We will now sketch the rooms on top of the background image. Remember that holding the ALT key down temporarily disables snap-to. Also, after you define any room, you can select the room and then select any of the points that define the shape and drag the point to adjust the shape.

To sketch the rooms:

  1. In the View toolbar, click Top View path ui icon view 2d top.
  2. Zoom in on the top left of the background image and, in the left toolbar, click Add a Polygonal Room path ui icon room polygon. Click to define the periphery of the room. Use a right-click to draw the last line that closes the polygon, as shown in Figure 4. How precise you want to be when defining the room boundaries depends on your goals. In general, the results of the evacuation analysis are relatively insensitive to exact precision of the room dimensions.
  3. With the created room selected, type 75% in the Opacity box. This will make the room 75% solid (25% transparent) so that the underlying background image can still be seen.
  4. Repeat for the adjacent office, as shown in Figure 5.
  5. We will now make copies of the second office. Select the second office, then, in the tools toolbar, click Copy/Move Objects path ui icon copy move. Select Copy Mode. In the Copies box, type 10. To define how far to move each copy, click on the lower right corner of the polygon that describes the office and then click on the corresponding point in the adjacent office, shown in Figure 6. The second click will make the copies, as shown in Figure 7.
  6. You will probably need to zoom in and adjust the exact positions of the offices. Select Normal Mode to move an office without making a copy. When completed, your model should resemble Figure 8.
path scrn blueprint first office
Figure 4. Sketch of first office
path scrn blueprint second office
Figure 5. Sketch of second office
path scrn blueprint second office copy
Figure 6. Preparing to copy second office
path scrn blueprint second office copies
Figure 7. After making copies of the second office
path scrn blueprint copied offices
Figure 8. The copied offices
  1. Continue to sketch the rooms. Figure 9 shows sketches made that go around furniture. As a second sketch is made next to an existing room, the cursor will snap to the existing room coordinates. Hold the CTRL key and select both rooms, then right-click and select Merge. Continue this process to complete the sketch.
  2. You can cut holes in an existing room by drawing a new polygonal room on the existing room and deleting the polygon.
  3. Continue the sketching process until you have made all the rooms for the office. Note that we can leave the walls with a finite thickness separating the rooms. After some time, your model should resemble Figure 10.
path scrn blueprint furniture
Figure 9. Sketching around furniture and then merging separate sketches to make one room
path scrn blueprint defined rooms
Figure 10. After all rooms have been defined. Note that some offices are separated by doors, so those rooms are not yet connected to the main walking space.

4. Add Doors

Doors are added to connect all offices to the open walking space.

  1. In the View toolbar, click Top View path ui icon view 2d top.
  2. Double-click Add a new Door path ui icon door. By default the doors are 32 inches wide. The Max Depth is the maximum thickness the tool will use to search for adjoining space. Depending on how accurately your model is sketched, you might need to increase the value.
  3. Zoom in to the upper left of the model and move the mouse to the location for the door and the tool will snap to the adjoining spaces as shown in Figure 11.
  4. Continue adding doors until your model resembles Figure 12.
path scrn blueprint add door
Figure 11. Adding a door to the model
path scrn blueprint doors added
Figure 12. After all doors have been added

5. Add Occupants

We will add 80 occupants, 50 placed in offices and open space and 20 and 10 placed in the two conference rooms.

  1. Double-click Add an Occupant path ui icon occupant single. Click to position 50 occupants in offices or open space, as shown in Figure 13.
  2. To add occupants to the conference room, right-click on the left conference room and in the context menu, click Add Occupants.
  3. For Placement, select Random. In the By Number box, type 20. Click OK to close the dialog and add the occupants, as shown in Figure 14.
  4. Repeat to add 10 occupants to the adjacent conference room.
path scrn blueprint individual occupants
Figure 13. Adding individual occupants to the model
path scrn blueprint occupants by room
Figure 14. Adding occupants by room

6. Run Simulation

To run the simulation:

  1. On the File menu, select Save.
  2. Save the model to a new folder on your computer and name the file fog_creek.pth.
  3. On the toolbar, click Run Simulation path ui icon run sim.

7. View Results

When the simulation is finished, the 3D Pathfinder results window will display.

To view results:

  1. Click the Play button.
  2. At any time click the Pause or Stop button. You can drag the time line to control the animation.
  3. To view occupants as people, click the Stop button, on the Agents menu, click Show as People, then click the Play button. Your simulation should resemble Figure 15.
path scrn blueprint results
Figure 15. The results during evacuation. They do dress nice at Fog Creek, don’t they?

To download the most recent version of Pathfinder, please visit the Pathfinder downloads page and click the link for the current release. If you have any questions, please contact support@thunderheadeng.com